Remote Lite Issue - 8/25/2020
Incident Report for Vyne Dental
Resolved
This incident has been resolved. If you have questions, please reach out to us at support@dentalhero.com.
Posted Aug 25, 2020 - 11:11 EDT
Identified
Our dental heroes have identified an issue impacting Remote Lite and are currently investigating the cause. We will provide updates as they become available.

If you have questions, please reach out to us at support@dentalhero.com.
Posted Aug 25, 2020 - 11:07 EDT