Batch Claims Outage
Incident Report for Vyne Dental
Resolved
This incident has been resolved.
Posted Mar 07, 2022 - 18:31 EST
Identified
We are still experiencing technical issues but have identified the issue, delivery of batch files should be back to normal tomorrow. Updates will be posted here.
Posted Mar 07, 2022 - 16:05 EST
Investigating
We are currently experiencing technical issues, delivery of batch files will be delayed. Updates will be posted here.
Posted Mar 07, 2022 - 11:10 EST
This incident affected: Tesia (Claims Processing).